<!DOCTYPE html>
<html lang="en-US">
<head>
<title>Alt-Rocker Mark Mulcahy Discovers His Voice On New Album - CT Now</title>
<meta charset="utf-8" />

      <link rel="dns-prefetch" href="//www.trbimg.com"
          /><link rel="preconnect" href="//www.trbimg.com"
        /><link rel="dns-prefetch" href="//static.chartbeat.com"
      /><link rel="dns-prefetch" href="//m.trb.com"
      /><link rel="preconnect" href="//m.trb.com"
      /><link rel="dns-prefetch" href="//b.scorecardresearch.com"
      /><link rel="preconnect" href="//b.scorecardresearch.com"
      /><link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"
      /><link rel="preconnect" href="https://securepubads.g.doubleclick.net"
      /><link rel="dns-prefetch" href="//pubads.g.doubleclick.net"
      /><link rel="preconnect" href="//pubads.g.doubleclick.net"
      /><link rel="dns-prefetch" href="//tpc.googlesyndication.com"
      /><link rel="preconnect" href="//tpc.googlesyndication.com"
      /><link rel="dns-prefetch" href="//www.google-analytics.com"
      /><link rel="preconnect" href="//www.google-analytics.com"
      /><link rel="dns-prefetch" href="//www.googletagservices.com"
      /><link rel="dns-prefetch" href="//partner.googleadservices.com"
      /><link rel="dns-prefetch" href="//cm.g.doubleclick.net"
      /><link rel=dns-prefetch href=//nexus.ensighten.com
    /><link rel="dns-prefetch" href="http://ssor.tribdss.com"
    /><link rel="dns-prefetch" href="http://www.tribdss.com"
    /><link rel="dns-prefetch" href="//cdn.krxd.net"
    /><link rel="preconnect" href="//cdn.krxd.net"
    /><link rel="dns-prefetch" href="//ads.rubiconproject.com"
    /><link rel="preconnect" href="//ads.rubiconproject.com"
    /><link rel="dns-prefetch" href="//optimized-by.rubiconproject.com"
    /><link rel="preconnect" href="//optimized-by.rubiconproject.com"
    /><link rel="dns-prefetch" href="//cdn.gigya.com"
    /><link rel="dns-prefetch" href="//static.yieldmo.com" 
    /><link rel="dns-prefetch" href="//s.yieldmo.com" 
    /><link rel="dns-prefetch" href="//ads.yieldmo.com" 
    /><link rel="dns-prefetch" href="//embed.solidopinion.com" 
    /><link rel="dns-prefetch" href="//cdn.taboola.com"
    /><link rel="preconnect" href="//cdn.taboola.com"
    />
    <meta http-equiv="Content-Language" content="en-US" />
        <meta name="robots" content="noodp, noydir" />
    <meta name="author" content="MICHAEL HAMAD" />
    <meta name="date" content="2017-06-19" />
      <meta name="copyright" content="Copyright (c) 2017 Hartford Courant" />
    <meta name="Description" content="With his band Miracle Legion having wrapped up its reunion tour, alt-rocker Mark Mulcahy will perform his new solo album &quot;The Possum in the Driveway&quot; at Lyric Hall in New Haven on June 22 at 8:30 p.m., with Paul Belbusti opening." />
    <meta name="keywords" content="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album, Miracle Legion, mark mulcahy, miracle legion, new haven, lyric hall, the possum in the driveway, connecticut music, concerts at lyric hall, things to do in new haven, alternative rock shows in ct" />
      <meta name="news_keywords" content="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album, Miracle Legion, mark mulcahy, miracle legion, new haven, lyric hall, the possum in the driveway, connecticut music, concerts at lyric hall, things to do in new haven, alternative rock shows in ct" />
    <meta name="fb_title" content="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album" />
        <meta property="og:title" content="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album" />
      <meta property="og:description" content="With his band Miracle Legion having wrapped up its reunion tour, alt-rocker Mark Mulcahy will perform his new solo album &quot;The Possum in the Driveway&quot; at Lyric Hall in New Haven on June 22 at 8:30 p.m., with Paul Belbusti opening." />
    <meta property="fb:page_id" content="312570883661" />
    <meta property="fb:app_id" content="272456773916"  />
    <meta property="og:type" content="article" />
    <meta property="og:url" content="http://www.ctnow.com/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" />
    <meta property="og:image" content="http://www.trbimg.com/img-5947d318/turbine/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" />
    <meta property="og:site_name" content="ctnow.com" />
    <meta name="twitter:card" content="summary" />
        <meta name="twitter:site" content="@GoToCTNow" />
      <meta itemprop="datePublished" content="2017-06-18T21:00:00-0700" />
      <meta itemprop="dateModified" content="2017-06-19T06:37:34-0700" />
    <meta name="robots" content="index,follow"  /><meta name="googlebot" content="index"  /><meta name="googlebot-news" content="index" /><link rel="canonical" href="http://www.courant.com/entertainment/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" /><link rel="amphtml" href="http://www.ctnow.com/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story,amp.html"><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
    <meta name="x-servername" content="i10prod-402ef6a-0-154.1"/>
  <meta property="so:status" content="5,1"/>
<script>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</script><script>i$={plugins:{},cache:{window:{innerHeight:window.innerHeight,innerWidth:window.innerWidth},document:{documentElement:{clientWidth:document.documentElement.clientWidth}}}};
trb={run:[],runInfuse:[],data:{page:{},videos:{},embed:{},metrics:{prdomain:"ctnow.com",pbrd:17}},vendor:{snt:{}},dpl:[],dpp:[]};
googletag={cmd:[]};trb.appendResource=function appendResource(i,g,f,h){var j=document.createElement(i);
if(i=="script"){j.src=g;j.async=f||false;j.defer=f||h||false;}else{if(i=="link"){j.href=g;j.rel="stylesheet";
}else{return;}}(document.head||document.documentElement).appendChild(j);};window.trb=window.trb||{};trb.utils=trb.utils||{};
trb.data=trb.data||{};trb.browsersupport=trb.browsersupport||{};trb.browsersupport.isMobile=function(){return/(android|bb\d+|meego).+mobile|bada\/|blackberry|fennec|iemobile|ip(hone|od|ad)|kindle|maemo|midp|mmp|netfront|opera m|palm|phone|p(ixi|re)\/|series(4|6)0|symbian|up\.(b|l)|vodafone|wap|windows (ce|phone)|android|playbook|silk/i.test(navigator.userAgent);
};trb.data.isMobile=trb.browsersupport.isMobile();if(trb.data.isMobile){document.documentElement.setAttribute("data-content-mobile","");
}(trb.userTiming=window.performance&&performance.mark&&location.hash.indexOf("trb_perf")>-1?function(b){performance.mark(b);
}:function(){})("trb head");_sf_startpt=Date.now&&Date.now();document.addEventListener&&document.addEventListener("DOMContentLoaded",function isReady(){i$.hasDocReadyRun=true;
});</script
><script>
    trb.data.parentSectionPath = '/music';
    trb.data.parentSectionName = 'Music';
    if (trb.data.isSectionFront = false) document.documentElement.setAttribute('data-content-sectionfront', '');
    
      trb.data.unsupportedBrowserBaseURL='http://touch.ctnow.com';
      trb.data.page = {unsupportedBrowserPath: '/#section/-1/article/p2p-93886069/'};
    </script
  >
             <script>
               trb.data.kruxEnabled = true;
               trb.data.kruxId = 'JucO7ms-';
               trb.data.ads = {slotPrefix : '/4011/trb.ctnow', rubicon: { enabled : true } };
               trb.data.page.ads = {enabled: true, slot: trb.data.ads.slotPrefix + '/' + 'ent/music', options: {"site":"trb.ctnow","tile":"1","ord":"88680054","dcopt":"ist","cid":"93886069","ptype":"s"}, rubicon: {keyFPI: '', valueFPI: ''}};
             </script>
           
                <script>
                  trb.data.ads.yieldmo = {mobile: true, desktop: false};
                </script>
              
        <script>
          trb.data.page.articleType = 'robust';
        </script>
      <script>trb.exop = trb.exopid ? 'true' : trb.data.page.articleType && document.cookie.indexOf('xop=0') > -1 ? 'control' : 'false';</script
>
      <script>
        (location.hash + location.search).indexOf ('disable-gpt') == -1 && trb.data.ads && trb.appendResource('script', '//www.googletagservices.com/tag/js/gpt.js', true);
        trb.appendResource('script', 'http://www.trbas.com/jive/prod/common/javascripts/lib.1q2w3_9176ee4680c2371c4026e5eeeb9cc691.min.js', true);
        trb.appendResource('script', 'http://www.trbas.com/jive/prod/common/javascripts/main.1q2w3_f1f9aaf15874c9c29864e1517fae6091.min.js', true);
      </script>
    
<script>trb.appendResource('script', trb.data.ssorUrl = 'http://ssor.tribdss.com/reg/tribune/ctnowngux.min.js', true);
</script>
  <script>
    
    trb.appendResource('script', trb.data.meteringUrl = 'http://www.tribdss.com/meter/ctnowngux.min.js', true);
  </script>
<script>googletag.cmd.push(function(){trb.userTiming("trb gpt load");});</script
><link rel=preload as=script href=//ads.rubiconproject.com/header/7476.js
    />
  <script>trb.run.push(function(){trb.ads.loadAdloader();});</script>
  <script>trb.run.push(function(){i$('mediamanager');});</script>
                          <script>trb.data.page.totalPages = 3;</script>
                        <script>
 trb.data.page.pathname = '/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html'; 
 trb.data.page.metrics = {"list1":"Michael Hamad","byline":"MICHAEL HAMAD","sectionPath":"/music/","sectionName":"Music","parentSectionName":"Music","slug":"hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621","premiumContentLevel":"default","pubDate":"06-19-2017 00:00","pageTitle":"Alt-Rocker Mark Mulcahy Discovers His Voice On New Album","uid":"32297","pageNumber":"","owner":"Hartford Courant","contentId":"93886069","marketCode":"hartnews","individualPhotoID":"93695749","topicID":"","topic":"","siteName":"ctnow","contentType":"story","linkTrackingAction":"story","channel":"music","server":"www.ctnow.com","pageName":"ctnow:music:hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621:story.","topLevelSection":"music","siteHierarchy":"ctnow:music","globalHierachy":"music","site":"ctnow","siteAbbrv":"ctnow","omnitureAccountId":"tribnglobal","googleAnalytics":"UA-29516296-1"};
 </script><script> 
    trb.data.page.metrics.relateditems = true;
  </script>
      <script>
        (location.hash + location.search).indexOf('disable-ensighten') == -1 && trb.appendResource('script', '//nexus.ensighten.com/tronc/ctnowngux' + (location.hash.indexOf('ensightenEnv=dev') > -1 ? 'dev' : 'prod') + '/Bootstrap.js', true);
      </script>
    <style>@font-face{font-family:trb_Icons;src:url('/as/prod/common/fonts/trbicons.1q2w3_4246b80465a23616ede433f92ea4efc2.woff2')format('woff2'),url('/as/prod/common/fonts/trbicons-new.1q2w3_0bcac650703402e43791d87964facdaa.woff')format('woff')}</style>
  <link rel="apple-touch-icon" href="http://www.trbas.com/jive/prod/common/images/ctnow-apple-touch-icon.1q2w3_0814f57c69f2e66efcdeb3b70f9dfeb2.png"
  ><link rel="prefetch" href="/as/prod/ctnow/stylesheets/modules.1q2w3_c264220884dcc6c36444489b0f3eb400.min.css"
    /><style>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</style>

  

  <script>trb.userTiming("trb css load");</script>
</head>
<body>
<svg style="display: none">
<symbol id="trb_facebook" viewBox="0 0 32 32"><path d="M9.125 16.125V11h2.938V8.25q0-3.25 1.563-4.75T18.69 2h3.75v4.875h-1.814q-1.688 0-2.188.47t-.5 2.093V11H22.5l-.624 5.126h-3.938V30h-5.875V16.127H9.125z"/></symbol><symbol id="trb_twitter" viewBox="0 0 32 32"><path d="M28.688 8.125q-1 1.625-2.625 2.688v.688q0 3.566-1.625 6.878T19.344 24t-8.03 2.314q-4.314 0-8-2.375.312.06 1.25.06 3.562 0 6.5-2.188-1.69-.063-3.032-1.063t-1.844-2.56q.875.124.938.124.75 0 1.375-.188-1.75-.375-2.935-1.813T4.375 13v-.064q.875.563 2.313.688Q4.375 12.06 4.375 9.25q0-1.376.75-2.564 4 5 10.688 5.375-.125-1-.125-1.122-.125-2.188 1.5-3.75t3.688-1.5 3.813 1.688Q26.44 7 27.94 6.06q-.564 1.876-2.25 2.876 1.75-.188 3-.813z"/></symbol><symbol id="trb_email" viewBox="0 0 32 32"><path d="M27.813 7.125L16 15.938 4.187 7.125h23.625zM2 24.875V8.187L16 18.75 30 8.187v16.688H2z"/></symbol><symbol id="trb_circle_play" viewBox="0 0 73.856 73.856"><path d="M55.928 36.9l-28 17.528v-35l28 17.472z"/><circle cx="36.8" cy="37" r="32" stroke="" stroke-width="5.8" fill="none"></circle></symbol><symbol id="trb_premium" viewBox="-379 291 32 32"><path d="M-349.8,307c0,0.8-0.7,1.4-1.5,1.4h-10.7v10.7c0,0.8-0.6,1.5-1.4,1.5c-0.8,0-1.4-0.7-1.4-1.5v-10.7h-10.7c-0.8,0-1.5-0.6-1.5-1.4s0.7-1.4,1.5-1.4h10.7v-10.7c0-0.8,0.6-1.5,1.4-1.5c0.8,0,1.4,0.7,1.4,1.5v10.7h10.7C-350.4,305.6-349.8,306.2-349.8,307z"/></symbol><symbol id="trb_thin_arrow_down" viewBox="0 0 31 32"><path d="M13.813 0v26.47L1.97 14.624 0 16.594 15.406 32l15.406-15.406-2.375-1.97L16.593 26.47V0h-2.78z"/></symbol><symbol id="trb_thin_close" viewBox="0 0 32 32"><path d="M15.313 15.938L3.813 4.5l.75-.688 11.375 11.5 11.438-11.5.813.688-11.565 11.438L28.19 27.5l-.814.69-11.438-11.44L4.563 28.19l-.75-.69z"/></symbol><symbol id="trb_arrow_expand" viewBox="0 0 32 32"><path d="M15.938 18.125L9 25h7.625v3H3.937V15.312H7V23l6.875-6.875zm.125-4.25L23 7h-7.624V4h12.688v12.688H25V9l-6.874 6.875z"/></symbol><symbol id="trb_video" viewBox="0 0 32 32"><path d="M2 7.063h21.938v6.125L30 9.75v12.688L23.94 19v5.938H2V7.063z"/></symbol><symbol id="trb_thin_arrow_next" viewBox="0 0 32 32"><path d="M21 15.938L9.562 4.5l.688-.688 12.188 12.125-12.188 12.25-.688-.688z"/></symbol><symbol id="trb_magnify_glass" viewBox="0 0 32 32"><path d="M25.313 13.375q0 4.188-2.75 7.313l6 6.063-2.75 2.877-6.375-6.5Q17 24.314 14.313 24.314q-4.5 0-7.688-3.188t-3.188-7.75q0-4.5 3.22-7.75t7.655-3.25q4.563 0 7.78 3.25t3.22 7.75zm-17.875 0q0 2.813 2 4.938 2.063 2.063 4.875 2.063t5-2.063q2.125-2.063 2.125-4.938 0-2.813-2.125-4.875-2.188-2.063-5-2.063T9.438 8.5q-2 2-2 4.875z"/></symbol></svg>


  

  
<div class="trb_allContentWrapper" data-content-section-path="/music/" data-role="pagination" data-state="transporter_active" lang="en-US" data-c-url="/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" data-content-id="93886069" data-content-slug="hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" data-content-section="Music" data-content-type="story"><img alt="" class="trb_pixelTracker" style="display:none;" src="https://pixel.sitescout.com/iap/d485a450486beeb2"/>





<header class="trb_mh trb_masthead"
  ><div class="trb_mh_adB trb_masthead_adBanner" 
      ><div class="trb_header_adBanner_combo" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="728x90" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="leaderboardcombo" data-adloader-adtype="mastheadleaderboardcombo" data-adloader-label ></div
       >
  <div class="trb_header_adBanner_large" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="728x90" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="headerLeaderboard" data-adloader-adtype="mastheadleaderboard" data-adloader-label ></div
       >
  <div class="trb_header_adBanner_small" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="320x50" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="headerMobileBanner" data-adloader-adtype="mastheadmobilebanner" data-adloader-label ></div
       >
  </div
   ></header>

<article class="trb_ar" itemscope itemtype="http://schema.org/Article">
  <header class="trb_ar_h">
    
<div class="trb_ar_bc">
      <a itemprop="articleSection" href="/music/#nt=breadcrumb" class="trb_ar_bc_a">Music </a>
        </div>
    
  <div class="trb_sc" data-role="sc_information sc_container" data-sc-c="page" data-sc-url="/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" data-sc-ti="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album" data-sc-th="http://www.trbimg.com/img-5947d318/turbine/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" data-sc-desc="Singer-songwriter Mark Mulcahy, who&apos;ll perform his entire new album, &quot;The Possum in the Driveway,&quot; at Lyric Hall in New Haven on June 22, is Connecticut alt-rock royalty. Mulcahy hoisted New Haven music up onto an international stage with Miracle Legion, the band he co-founded with guitarist Mr...." data-sc-sl="hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" data-sc-cont="story" data-sc-nn="CT Now" data-sc-contid="93886069"><span class="trb_sc_item" data-role="sc_share" data-sc-t="facebook" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_facebook"
  /></svg
></span
  ><span class="trb_sc_item" data-role="sc_share" data-sc-t="twitter" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_twitter"
  /></svg
></span
  ><span class="trb_sc_item" data-role="sc_email" data-sc-t="email" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_email"
  /></svg
></span
  ></div
      >
  <div class="trb_ar_hl">
      <h1 class="trb_ar_hl_t" itemprop="headline">Alt-Rocker Mark Mulcahy Discovers His Voice On New Album</h1>
    </div>
    <div class="trb_ar_la"><aside class="trb_em " data-content-embedlocation="Content level lead art" data-content-id="93695749" data-content-size="leadart" data-content-type="video" data-content-slug="hc-mark-mulcahy-plays-lyric-hall-in-20170615" data-content-subtype="premiumvideo" data-role="sc_item  mediamanager_container imgsize_ratiosizecontainer " data-state="">        <div class="trb_em_m">          <div itemprop="video" class="trb_video_embeddedvideo" data-role="mediamanager_item" data-state="thumbnail" data-content-subtype="premiumvideo"            data-content-playtime="00:32"      ><a class="trb_video_embeddedvideo_a"  data-role=" mediamanager_trigger" id="93695749" data-video-attributes='{"player_id":"B18m3E6v","player_id_mobile":"rJg5bv5K","url":"/music/93695749-132.html","type": "brightcove", "as": "true", "le": "/common/video-errors.xml", "section_name": "video","sub_type":"premiumvideo","video_id":"5472759800001","vidcontent":"Entertainment","videoOwner":"Hartford Courant","videos":"Mark Mulcahy plays Lyric Hall in New Haven/93695749/Hartford Courant", "content_item_type": "","omniture_server": "", "omniture_account": "", "width": "920", "height": "518","account_id": "3690581449001","avp": "93695749"}'  data-state="" href="#"  onclick="return false;">      <figure data-role="delayload  delayload_done imgsize_item" class="trb_video_embeddedvideo_figure">      <svg class="trb_video_embeddedvideo_figure_video_svg"    ><use xlink:href="#trb_circle_play"  /></svg><svg class="trb_video_embeddedvideo_figure_premium_svg"    ><use xlink:href="#trb_premium"  /></svg><img  data-baseurl="http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615" alt="Mark Mulcahy plays Lyric Hall in New Haven" data-state="imgsize_srcRetained" class="trb_video_embeddedvideo_img" title="Mark Mulcahy plays Lyric Hall in New Haven" data-c-nd="2048x1365" data-role="imgsize_srcsetdisplayitem" srcset="http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/350/350x197 350w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/400/400x225 400w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/450/450x253 450w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/500/500x281 500w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/550/550x309 550w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/600/600x338 600w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/650/650x366 650w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/700/700x394 700w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/750/750x422 750w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/800/800x450 800w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/850/850x478 850w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/900/900x506 900w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/950/950x534 950w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1000/1000x563 1000w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1050/1050x591 1050w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1100/1100x619 1100w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1150/1150x647 1150w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1200/1200x675 1200w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1400/1400x788 1400w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1600/1600x900 1600w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/1800/1800x1013 1800w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/2000/2000x1125 2000w, http://www.trbimg.com/img-5947d2eb/turbine/hc-mark-mulcahy-plays-lyric-hall-in-20170615/2048/2048x1152 2048w" sizes="(min-width: 1240px) 1150px, (min-width: 1060px) calc(100vw - 139px), 100.1vw" /></figure>  </a>    </div><div class="trb_em_r" data-role="lightbox_metadata" >            <span class="trb_embed_related_title" data-relateditem-title="Mark Mulcahy plays Lyric Hall in New Haven"></span>      <div class="trb_embed_related_caption"><p>The Miracle Legion frontman's new album, "The Possum in the Driveway," was released in April. <a href="http://www.ctnow.com/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" target="_blank">Read story here</a>.</p></div>      <div class="trb_embed_related_credit_and_caption"><p>The Miracle Legion frontman's new album, "The Possum in the Driveway," was released in April. <a href="http://www.ctnow.com/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" target="_blank">Read story here</a>.</p></div></div>                </div></aside></div>
    </header>
 <div class="trb_ar_main">
          <div
            ><div class="trb_ar_by"
      ><figure class="trb_ar_by_i_f"><img src="http://www.trbimg.com/img-5661ac70/turbine/hc-michael-hamad/70/70x70" srcset="http://www.trbimg.com/img-5661ac70/turbine/hc-michael-hamad/140/140x140 2x, http://www.trbimg.com/img-5661ac70/turbine/hc-michael-hamad/210/210x210 3x" alt="Michael Hamad" width="70" height="70" title="Michael Hamad" class="trb_ar_by_i"></figure
                  ><span class="trb_ar_by_nm_pm"
        ><span data-byline-withoutby class="trb_ar_by_nm_au"><a itemprop="author" href="/hc-michael-hamad-staff.html#nt=byline" class="trb_ar_by_nm_au_a">Michael Hamad</a
></span
          ><span class="trb_ar_by_b"></span
      ><a class="trb_ar_by_cl" href="mailto:mhamad@ctnow.com?subject=Regarding: &quot;Alt-Rocker Mark Mulcahy Discovers His Voice On New Album&quot;" data-role="sc_sEmail">Contact Reporter</a
    ></span
    ></div
  ><div class="trb_ar_dateline"><time itemprop="datePublished" class="trb_ar_dateline_time" data-dt="June 19, 2017" datetime="2017-06-19T00:00:00EDT"></time>
  </div>
    </div>
            <div itemprop="articleBody">
                    
                        <div class="trb_ar_page"  data-role="pagination_page" data-content-page="1">
                          <p>Singer-songwriter Mark Mulcahy, who'll perform his entire new album, &quot;The Possum in the Driveway,&quot; at Lyric Hall in New Haven on June 22, is Connecticut alt-rock royalty. Mulcahy hoisted New Haven music up onto an international stage with Miracle Legion, the band he co-founded with guitarist Mr. Ray Neal in 1983, then expanded young minds with Polaris, in the cult-classic kids show &quot;The Adventures of Pete &amp; Pete.&quot; For the last two decades, he's been putting out critically acclaimed solo records; he continues to write, record and tour while raising two daughters in Springfield, Mass.</p><p>&quot;Possum,&quot; tracked over several years in three different spaces (including J Mascis' Bisquiteen studio) and released at the end of April, shows off sides of Mulcahy we've not heard before. Unfolding in fits and starts, it's like his version of a psychedelic rock record; producer Scott Amore, often working alone, bathed Mulcahy's voice in layers of delays and reverb, surrounding melodies and grooves with guitars, woodwinds, horns, voices and keyboards, on songs like the bluesy &quot;The Fiddler,&quot; a gorgeous song called &quot;Conflicted Interests&quot; and &quot;Geraldine,&quot; the symphonic six-minute closer.</p><div class="trb_gptAd trb_ar_main_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="articleCube" data-adloader-adtype="articlebottomcube" data-adloader-label ></div
       ><p>Last year, Mulcahy and Mr. Ray <a href="http://www.courant.com/entertainment/music/hc-miracle-legion-ballroom-outer-space-hamden-0714-20160714-story.html" target="_blank">reformed Miracle Legion for a reunion tour</a>, which wrapped earlier this spring. Over breakfast in Springfield, Mulcahy talked at length about his new album, the future of Miracle Legion, what to expect at Lyric Hall and other topics.</p><p><strong>Q:</strong> Miracle Legion recently stopped touring. Will that be it for awhile?</p><div class="trb_ar_cont" data-ar-cont="Article continues below"><svg class="trb_ar_cont_svg"
    ><use xlink:href="#trb_thin_arrow_down"
  /></svg
></div>
            <aside class="trb_ar_sponsoredmod" data-v-ymid="ym_1382639492343168210" data-adloader-networktype="yieldmo" data-role="delayload delayload_item" data-screen-size='mobile' data-withinviewport-options="bottomOffset=100&topOffset=1000000" data-load-method="trb.vendor.yieldmo.init" data-load-type="method" >
            </aside><p><strong>A:</strong> When we were going on, nobody was thinking, &quot;Well, this is it boys.&quot; Having said that, I don't know when we would do it again, or why. It was a particularly good bunch of shows this time. We did two rounds of reunions. The first one was very good. We played a bunch of shows, and we all really dug it. We did another 10 shows during that second bit, and it felt more like we actually used to be, when we were really a band. We were almost better than we used to be, in a weird kind of way. It was pretty great actually. We were really like a trio with a singer that went at it kind of hard. We weren't as hard as the Who or a lot of other bands. [The Who was playing on the overhead speakers at the coffee shop.] Playing with those dudes was great.</p><p><strong>Q: </strong>&quot;The Possum in the Driveway,&quot; your latest album, evolved over a long period of time. Some songs predated 2013's &quot;Dear Mark J. Mulcahy, I Love You.&quot;</p><p><strong>A:</strong> Yes. I worked on [&quot;Possum&quot;] steadily, which is what you do, when you can, and then I just quit doing it for three years. When I was ready to put a record out, I thought, &quot;Well, here's that thing that's all ready to go.&quot; I hadn't written those kinds of songs in a little while. I thought, &quot;Maybe I should write some songs in a style that I would write now,&quot; whatever that is. So I went about it in a different way: I wrote one song a day, recorded it, got a bunch of guys each time. It's a much more forward-moving process than having a thing and then working backward.</p><p><strong>Q:</strong> &quot;Possum&quot; was also recorded at several different studios. Does it hang together, in your mind?</p><p><strong>A:</strong> Does it have an identity? Yes. Scott Amore was the producer. I've had producers a couple of times, but not too much. There's always somebody who's the other guy, the production guy. But Scott really produced it more than I realized he was doing. He was working on it when there was nobody there, adding textures and sounds. I've worked on records where you say, &quot;OK, this is the last day. We're done. I know this is the last day.&quot; [&quot;Possum&quot;] wasn't like that.</p><p>Some of the songs were much longer than they are. I don't know what I was thinking at the time: &quot;This song would be really great if it was 10 minutes long.&quot; It wasn't as great. We edited some of them. Mainly, they were done. Scott turned it into the thing that it is, because of that overall soak of reverbs and delays and things, and he really made the vocals a lot louder than I would have, louder than I would have agreed to if I was sitting there.</p><p><strong>Q:</strong> Why is that?</p><p><strong>A:</strong> Nobody wants to be interviewed, or hear themselves talk, or have pictures taken. Anything that's you is magnified [when you hear it back]. But I thought, &quot;That's so weird, and suitable,&quot; in the context of the soupiness that he had invented, and in the context of the instruments that we used. He has a lot of strange old keyboards, and there were a lot of organic moments of horns. [With horns] there's nothing electronic. There's no amp. It's like an acoustic guitar, but even more so. It's such an extension of a person, to hear a trumpet or a saxophone. It's like a voice, in a way. Those things all combine — he even made those sound strange. A lot of credit to him, really, for managing the thing to a good place.</p><p><strong>Q:</strong> Did Scott come to you with these production ideas?</p><p><strong>A:</strong> He didn't come to anybody. He didn't ask anybody. He's kind of like that. Early on, before we took a break with it, I was like, &quot;I don't know, man. It's all whacked out.&quot; In a way, the first time he sent me some mixes, I thought, &quot;That doesn't sound like I thought it would sound, but it sounds great.&quot; Then we'd go to a place, and he'd come. He was always kind of like the lifeguard, watching everybody doing something. He always had a couple of hard drives in his hands, ready to plug in some other thing.</p><p>I give credit to all the other musicians. There was less studio spontaneity than I've experienced. Usually, you come in and somebody will start playing. You go, &quot;Yeah, how about if you try it the other way or that way?&quot; You work it out together. But most of the parts [on &quot;Possum&quot;] were written on the musicians' own time, without the idea of coming up with it on the spot. Everyone is more comfortable at home, alone, thinking of things they want to play. It's a lot easier than, &quot;Now I'm singing while you're watching me in the other room.&quot; So, these parts were all created outside of the studio, and then we just recorded them. There's a three-part clarinet suite that the guy came up with, or the guitar leads.</p><p>It was like classical music. I've had classical musicians in the studio, and they're kind of lost without a written part. That's how they think: &quot;If I look at it, I can play it.&quot; They're great players, but they want to read [a part], which is foreign to me. So, everything about [&quot;Possum&quot;] was done in a strange way. This is like a built record, in a ramshackle way. It had a strange hybrid of approaches.</p></div>
                      
                        <div class="trb_ar_page"  data-role="pagination_page" data-content-page="2">
                          <p><strong>Q:</strong> You booked only three shows, including the one at Lyric Hall in New Haven, to play the music from &quot;Possum.&quot;</p><p><strong>A:</strong> Yes. It's with all the guys [from the album]. It's not like classical music, but everyone is basically going to be playing what they played on the record. It's seven or eight guys, which I've done once in awhile just for fun, but I never really had that practice. [Lyric Hall] was the first place we thought of, because I played there with the Butterflies of Love. It's in Westville, which is a specific part of New Haven that never found myself in that often. Maybe I should have.</p><div class="trb_gptAd trb_ar_main_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlebottomcube" data-adloader-label ></div
       ><p>We've been rehearsing up in Easthampton [Mass.]. It's been sounding pretty good. I haven't been playing guitar on anything, which has been really fun for me. There are three guitar players already, so I don't know why we would need a bad guitarist we need when we have three good ones.</p><p><strong>Q:</strong> What's it like to be the lead singer, without holding a guitar?</p><p><strong>A:</strong> It's good. I got away from it. In Miracle Legion, I was always the lead singer. When we started playing again, I got back to that. I was like, &quot;Wow, this is so much better than playing guitar.&quot; The one thing about the guitar is you can kind of run the show a little bit. You can be a participant in how the music's going more than just being the singer. The singer has no say in anything, unless he looks at somebody. You can't really contribute to the music in that way.</p><p>A lot of guys in this group can play everything. Two guys are from New Haven, and the rest are from Northampton. Scott will probably record these shows. And that will pretty much be it. I don't see any way we can do this again, unless somebody said something weird, like, &quot;Do you want to do this in Chicago?&quot; It's too many guys. It's really hard to get that many people in one place, unless it's a real job. Everyone has their own jobs.</p><p><strong>Q:</strong> Do you tune into a lot of new music? Do you have a reliable way to discover new bands?</p><p><strong>A:</strong> Not really. I don't know that much. I bump into something — is it Big Thief? I really like them. But I don't have that much drive to find [new music], and I wish I did. I used to be very interested in knowing. I hear things, and I'm like, &quot;Wow, that is so good.&quot; I saw this band last weekend called the Chandler Travis Three-o, but it was like six guys. He's an eccentric dude, and I thought it was kind of a joke, but he was so good. I couldn't believe how great it was. He wears a bathrobe, and it's a weird instrumentation, but the players were amazing. There's a lot out there.</p><p><strong>Q: </strong>When did you discover that you have a good voice? Did you always know you could be a singer?</p><p><strong>A:</strong> Not so much. I was a drummer in a bunch of bands with Mr. Ray. He was the side guitar player. Then they'd split up, and you're the drummer, so you've got nothing. We'd try to start our own band, you know? He didn't really sing at all — Ray's not a singer — so I thought I would sing. That's kind of how it started.</p><p>I was the drummer in a band called Dump Truck. Those are some dudes that I played with a lot, and I was starting up Miracle Legion. They moved to Boston, and they asked if I wanted to come. I was like, &quot;Eh, I don't know, maybe,&quot; but I didn't really. I thought about it. So I was in both bands. They called me and said, &quot;We've got somebody else.&quot; I'd been a drummer my whole life: what do I do now? I was like, &quot;Okay, I guess I'm a singer.&quot; It was all by default.</p><p>Not to sound too grandiose, it's been a great experience to sing and make records and just try things with your voice, just to try things and see how you can surprise yourself and what you can try to do. It's just like everything else: there's so much to find out.</p><p><strong>Q: </strong>You used so many different sides of your voice on &quot;Possum.&quot; It's not just the processing; it's also the way that you are singing on different tracks. I can hear you trying out what your voice is capable of.</p><p><strong>A:</strong> Yeah. Especially since digital recording, I'll use as many different tracks as anybody will tolerate. I was actually watching a clip of me recording vocals for this record. I was surprised how hard it was to get it, you know? They're like, &quot;No, no, man, it's this.&quot; Especially when there are a lot of vocals, it gets confusing, knowing where you're supposed to be. I just love it. I love to multi-track.</p><p>I've done some operas [&quot;The Slug Bearers of Kayrol Island, or, The Friends of Dr. Rushower&quot; and &quot;The Rosenbach Company&quot;] with this guy, Ben Katchor. I'd write the music on GarageBand [software] and make up a bunch of vocals, and then the three singers in the opera were supposed to sing it. I didn't have anything written out. Dave [McCaffrey], said, &quot;I can write it out, if you want.&quot; He wrote out the vocal charts and handed them out, and everybody sang it perfectly. It's great when two things intersect: something you made up in your brain and when somebody writes it down.</p><p><strong>Q: </strong>Do you have a home studio to mess around with?</p><p><strong>A:</strong> Just GarageBand. I made my first record on a one-inch eight-track. When I finished it, [the producer] said, &quot;I have an extra one: why don't you take it home?&quot; So I did. I got a [mixing] board and all this stuff. Immediately, I was like, &quot;I don't know how to do this.&quot; The tape's flopping around on the reel. It was too much, so I quit that. Then I got Pro Tools [software], and I was like, &quot;I don't know how to do this. What am I going to do?&quot;</p><p>A friend suggested GarageBand. I was like, &quot;Isn't that some sort of stupid toy that they put in there for people who don't know how to record?&quot; He was like, &quot;Dude, start recording.&quot; I was like, &quot;Oh my god.&quot;</p><p><strong>Q: </strong>Are you a prolific songwriter?</p><p><strong>A:</strong> I wouldn't say I'm prolific, but I keep up with it. That's the best I can do. It seems like it comes in waves. It's the one thing I keep up with. You read about writers, how they do it every day from 6 to 8 a.m. They write 12 pages a day, and they really have a system. I would love to do that. I'm not really in a position to do that at the moment, but I plan to do that. I like to make up stuff. I don't care what I make up, you know? If it sucks, then it sucks.</p><p>I've tried writing prose, but it's a struggle to write a long thing for me. With lyrics, they're over quicker. I look at novels, and I'm like, &quot;Wow.&quot; That's just a talent that someone has. They don't mind. They write page after page after page. My kids read Harry Potter like crazy. It's so many words, and it's not easy.</p></div>
                      
                        <div class="trb_ar_page"  data-role="pagination_page" data-content-page="3">
                          <p><strong>Q:</strong> Songs often have lives after they're written and recorded, in cover version by other artists, or whatever. Does that enter your mind when you're writing?</p><p><strong>A:</strong> I just don't know how to do that. I've written songs where it has occurred to me that somebody else could do it. I've told this story many times, but I once sent music to the Backstreet Boys. I said, &quot;These couple songs would be perfect for them.&quot; It didn't work out, obviously. I wish that would happen to me. I've been listening to Randy Newman a lot. His thing is not so much that Randy Newman has a bunch of hits, but that he's written a lot of songs for other people. That would be the better life for me, you know? I've tried it. I've approached publishers and said I'd like to try to write with someone who is maybe younger and newer, someone hasn't written a lot of songs but they're trying to make a record and they don't quite know how to do it. I thought I could really bring some experience to that, to either write songs with them or take the songs they have and make them — I have a certain level of organization in my head about how songs should go.</p><div class="trb_gptAd trb_ar_main_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlebottomcube" data-adloader-label ></div
       ><p>The music business is a big trampoline of luck. Either you're in the right place, and somebody goes, &quot;Oh yeah, I love that guy,&quot; or you meet someone or somebody hears about you. It's hard to engineer it. Some guys are really smart. They get in there, and they really know how to make the right move. When you try to get to someone like the Backstreet Boys, there's such a wall. The guys who are doing all the stuff that you want to do: they're doing it, and they're like, &quot;What are you doing here?&quot;</p><p>I read an article a few years ago about these four Swedish guys who are write all the pop music that everybody hears. They are the guys. I don't remember the details, but I was like, &quot;Why do those guys get to do that?&quot; But they do: &quot;You want to get in here? No, the four of us got it.&quot; And they know how to do it. I'm not diminishing what they're doing. It's not easy to write a hit for whoever, you know?</p><p><strong>MARK MULCAHY </strong><em>performs at Lyric Hall in New Haven on June 22 at 8:30 p.m., with Paul Belbusti opening. Tickets are $20. <a href="http://lyrichallnewhaven.com" target="_blank">lyrichallnewhaven.com</a></em></p><aside class="trb_em " data-content-embedlocation="Embed + (1)" data-content-id="87789604" data-content-size="large" data-content-type="video" data-content-slug="hc-who-else-is-playing-this-week-20160706" data-content-subtype="premiumvideo" data-role="sc_item  mediamanager_container  imgsize_ratiosizecontainer lightbox_container  " data-state="" data-embed-id="87789604">        <div class="trb_em_mb"><span class="trb_em_m_cl" data-role="lightbox_close"><svg class="trb_em_m_cl_svg"    ><use xlink:href="#trb_thin_close"  /></svg></span>    <div class="trb_em_m">        <span class="trb_embed_media_info" data-role="embed_info lightbox_info"></span>  <div itemprop="video" class="trb_video_embeddedvideo" data-role="mediamanager_item" data-state="thumbnail" data-content-subtype="premiumvideo"            data-content-playtime="00:31"      ><a class="trb_video_embeddedvideo_a"  data-role=" mediamanager_trigger" id="87789604" data-video-attributes='{"player_id":"B18m3E6v","player_id_mobile":"rJg5bv5K","url":"/music/87789604-132.html","type": "brightcove", "as": "true", "le": "/common/video-errors.xml", "section_name": "video","sub_type":"premiumvideo","video_id":"5023491074001","vidcontent":"Entertainment","videoOwner":"Hartford Courant","videos":"Upcoming Concerts/87789604/Hartford Courant", "content_item_type": "","omniture_server": "", "omniture_account": "", "width": "900", "height": "506","account_id": "3690581449001","avp": "87789604"}'  data-state="" href="#"  onclick="return false;">      <figure data-role="delayload  delayload_done imgsize_item" class="trb_video_embeddedvideo_figure">      <svg class="trb_video_embeddedvideo_figure_video_svg"    ><use xlink:href="#trb_circle_play"  /></svg><svg class="trb_video_embeddedvideo_figure_premium_svg"    ><use xlink:href="#trb_premium"  /></svg><img  data-baseurl="http://www.trbimg.com/img-5942b13c/turbine/hc-who-else-is-playing-this-week-20160706" alt="Upcoming Concerts" class="trb_video_embeddedvideo_img" title="Upcoming Concerts" data-c-nd="2048x1349" /></figure>  </a>    </div>  <span class="trb_em_m_op" data-role="lightbox_open"><svg class="trb_em_m_op_svg"    ><use xlink:href="#trb_arrow_expand"  /></svg></span><div class="trb_em_r" data-role="lightbox_metadata" >            <span class="trb_embed_related_title" data-relateditem-title="Upcoming Concerts"></span>      <div class="trb_embed_related_caption"><p>Upcoming concerts: Read about these shows and more at <a href="http://ctnow.com/music" target="_blank">ctnow.com/music</a>.</p></div>      <div class="trb_embed_related_credit_and_caption"><p>Upcoming concerts: Read about these shows and more at <a href="http://ctnow.com/music" target="_blank">ctnow.com/music</a>.</p></div>  <div class="trb_sc" data-role="sc_information sc_container" data-sc-c="page" data-sc-url="/music/87789604-132.html" data-sc-ti="Upcoming Concerts" data-sc-th="http://www.trbimg.com/img-5942b13c/turbine/hc-who-else-is-playing-this-week-20160706" data-sc-desc="Upcoming concerts: Read about these shows and more at ctnow.com/music." data-sc-sl="hc-who-else-is-playing-this-week-20160706" data-sc-cont="premiumvideo" data-sc-nn="CT Now" data-sc-contid="87789604"><span class="trb_sc_item" data-role="sc_share" data-sc-t="facebook"       ><svg class="trb_sc_item_svg"    ><use xlink:href="#trb_facebook"  /></svg></span  ><span class="trb_sc_item" data-role="sc_share" data-sc-t="twitter"       ><svg class="trb_sc_item_svg"    ><use xlink:href="#trb_twitter"  /></svg></span  ><span class="trb_sc_item" data-role="sc_email" data-sc-t="email"       ><svg class="trb_sc_item_svg"    ><use xlink:href="#trb_email"  /></svg></span  ></div      >  <a class="trb_lightbox_moreVideosLink" href="/videos/"><svg class="trb_lightbox_moreVideosLink_video_svg"    ><use xlink:href="#trb_video"  /></svg>See more videos<svg class="trb_lightbox_moreVideosLink_next_svg"    ><use xlink:href="#trb_thin_arrow_next"  /></svg></a></div>                <div class="trb_gptAd" data-role="adloader adloader_ad" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="lightBoxCube" data-adloader-adtype="cube" data-adloader-positionoverride="lb" data-adloader-label ></div       >  </div></div></aside><div class="trb_eg trb_eg_b" data-role="base_eg delayload base_expandable" data-load-event="base_loadjointeg" data-eg-type="embedRelated"></div></div>
                      </div>
          <div class="trb_ar_cr">Copyright
            &copy; 2017, <a class="trb_ar_cr_a" href="http://www.ctnow.com/">CT Now</a></div>
        
  <div class="trb_sc" data-role="sc_information sc_container" data-sc-c="page" data-sc-url="/music/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621-story.html" data-sc-ti="Alt-Rocker Mark Mulcahy Discovers His Voice On New Album" data-sc-th="http://www.trbimg.com/img-5947d318/turbine/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" data-sc-desc="Singer-songwriter Mark Mulcahy, who&apos;ll perform his entire new album, &quot;The Possum in the Driveway,&quot; at Lyric Hall in New Haven on June 22, is Connecticut alt-rock royalty. Mulcahy hoisted New Haven music up onto an international stage with Miracle Legion, the band he co-founded with guitarist Mr...." data-sc-sl="hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621" data-sc-cont="story" data-sc-nn="CT Now" data-sc-contid="93886069"><span class="trb_sc_item" data-role="sc_share" data-sc-t="facebook" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_facebook"
  /></svg
></span
  ><span class="trb_sc_item" data-role="sc_share" data-sc-t="twitter" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_twitter"
  /></svg
></span
  ><span class="trb_sc_item" data-role="sc_email" data-sc-t="email" 
      ><svg class="trb_sc_item_svg"
    ><use xlink:href="#trb_email"
  /></svg
></span
  ></div
      >
  <div class="trb_gptAd trb_ar_main_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="pageBottomCube" data-adloader-adtype="articlebottomcube" data-adloader-label ></div
       >
  
  
  <div class=" trb_cm" data-role="cm_expandable">
    <div class="trb_cm_b" data-role="cm_expander" data-cm-label="Be the first to comment" data-cm-t="so"></div>
    <!-- .trb_cm_b:before{content:'Hide comments'}.trb_cm_so{padding-top:10px;min-height:500px}||<div class="trb_cm_so" data-role=cm_container><div class="so_comments" data-sitename="ctnowprod" data-content-id="ctnow93886069" data-type=promo-comment data-publisher="tronc"></div></div> -->
        </div>
  <div class="trb_taboola trb_ar_taboola" data-role="delayload" data-load-method="trb.vendor.taboola.init" data-load-type="method" data-vendor-taboolacontenttype="article" data-vendor-taboolarows="2"></div>
      </div>
      </article>
      <aside class="trb_ar_rail"><div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="articlecubecombo" data-adloader-adtype="articlecubecombo" data-adloader-label ></div
       >
  <div class="trb_eg" data-role="base_expandable base_eg" data-eg-type="related" data-eg-count="5" >
<ul class="trb_eg_u" data-eg-title="Related" data-role="base_egl">
  <li class="trb_eg_i" data-content-id="85722045" data-content-slug="hc-press-play-connecticut-underground-music-scene-sl" 
      ><a href="/music/hc-press-play-connecticut-underground-music-scene-sl-storygallery.html#nt=related-content" class="trb_eg_f"><img src="http://www.trbimg.com/img-58ecc35e/turbine/hc-press-play-connecticut-underground-music-scene-sl/70/70x70" srcset="http://www.trbimg.com/img-58ecc35e/turbine/hc-press-play-connecticut-underground-music-scene-sl/140/140x140 2x, http://www.trbimg.com/img-58ecc35e/turbine/hc-press-play-connecticut-underground-music-scene-sl/210/210x210 3x" height="70" width="70" class="trb_eg_img"/></a><h4 class="trb_eg_h"><a href="/music/hc-press-play-connecticut-underground-music-scene-sl-storygallery.html#nt=related-content" class="trb_eg_h_a" >Press Play: Connecticut's Underground Music Scene</a></h4>
        <span class="trb_eg_t" data-dt="JAN. 28, 2016" ></span></li>
      <li class="trb_eg_i" data-content-id="77998933" data-content-slug="hc-upcoming-concerts-in-connecticut-20131031" 
      ><a href="http://www.ctnow.com/music/ctn-upcoming-concerts-in-connecticut-20110216-photogallery.html" class="trb_eg_f"><img src="http://www.trbimg.com/img-593e9aed/turbine/hc-upcoming-concerts-in-connecticut-20131031/70/70x70" srcset="http://www.trbimg.com/img-593e9aed/turbine/hc-upcoming-concerts-in-connecticut-20131031/140/140x140 2x, http://www.trbimg.com/img-593e9aed/turbine/hc-upcoming-concerts-in-connecticut-20131031/210/210x210 3x" height="70" width="70" class="trb_eg_img"/></a><h4 class="trb_eg_h"><a href="http://www.ctnow.com/music/ctn-upcoming-concerts-in-connecticut-20110216-photogallery.html" class="trb_eg_h_a" >Upcoming Concerts</a></h4>
        <span class="trb_eg_t" data-dt="OCT. 31, 2013" ></span></li>
      <li class="trb_eg_i" data-content-id="86941428" data-content-slug="ctnow-2016-ct-music-award-winners-20160428" 
      ><a href="http://www.ctnow.com/music/ct-music-awards/hc-pics-best-of-new-haven-ct-music-20160426-photogallery.html" class="trb_eg_f"><img src="http://www.trbimg.com/img-57220805/turbine/ctnow-2016-ct-music-award-winners-20160428/70/70x70" srcset="http://www.trbimg.com/img-57220805/turbine/ctnow-2016-ct-music-award-winners-20160428/140/140x140 2x, http://www.trbimg.com/img-57220805/turbine/ctnow-2016-ct-music-award-winners-20160428/210/210x210 3x" height="70" width="70" class="trb_eg_img"/></a><h4 class="trb_eg_h"><a href="http://www.ctnow.com/music/ct-music-awards/hc-pics-best-of-new-haven-ct-music-20160426-photogallery.html" class="trb_eg_h_a" >2016 CT Music Award Winners</a></h4>
        <span class="trb_eg_t" data-dt="APR. 28, 2016" ></span></li>
      <!-- <li class="trb_eg_i" data-content-id="80004714" data-content-slug="ctn-more-events-on-our-music-page-20140424" 
      ><a href="http://www.ctnow.com/music/" class="trb_eg_f"><img src="http://www.trbimg.com/img-53598393/turbine/ctn-more-events-on-our-music-page-20140424/70/70x70" srcset="http://www.trbimg.com/img-53598393/turbine/ctn-more-events-on-our-music-page-20140424/140/140x140 2x, http://www.trbimg.com/img-53598393/turbine/ctn-more-events-on-our-music-page-20140424/210/210x210 3x" height="70" width="70" class="trb_eg_img"/></a><h4 class="trb_eg_h"><a href="http://www.ctnow.com/music/" class="trb_eg_h_a" >More Events On Our Music Page</a></h4>
        <span class="trb_eg_t" data-dt="APR. 24, 2014" ></span></li>
      <li class="trb_eg_i" data-content-id="81337091" data-content-slug="hc-things-to-do-hyperlink" 
      ><a href="http://www.ctnow.com/things-to-do/hc-things-to-do-in-connecticut-20120116-photogallery.html" class="trb_eg_f"><img src="http://www.trbimg.com/img-593e9b7c/turbine/hc-things-to-do-hyperlink/70/70x70" srcset="http://www.trbimg.com/img-593e9b7c/turbine/hc-things-to-do-hyperlink/140/140x140 2x, http://www.trbimg.com/img-593e9b7c/turbine/hc-things-to-do-hyperlink/210/210x210 3x" height="70" width="70" class="trb_eg_img"/></a><h4 class="trb_eg_h"><a href="http://www.ctnow.com/things-to-do/hc-things-to-do-in-connecticut-20120116-photogallery.html" class="trb_eg_h_a" >Things To Do In Connecticut</a></h4>
        <span class="trb_eg_t" data-dt="JUN. 29, 2015" ></span></li>
       --></ul>
  <a href="#" data-role="base_expander" data-eg-more="See More" data-eg-less="See Less" class="trb_eg_ex"></a></div>
<div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_ar_rail_ad" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="300x250" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100"  data-adloader-position="articleCube" data-adloader-adtype="articlecube" data-adloader-label ></div
       ></aside>
        <div class="trb_ar_e_d" data-role="extendablePage_summaryStart" data-load-type="scrollintoview"></div>
        
   
  



 

 
 














<div class="trb_bottomAdBanner">
  <div class="trb_gptAd trb_footer_adBanner_combo" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="728x90" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="footerleaderboardcombo" data-adloader-adtype="leaderboardcombo" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_footer_adBanner_large" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="728x90" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="footerLeaderboard" data-adloader-adtype="leaderboard" data-adloader-label ></div
       >
  <div class="trb_gptAd trb_footer_adBanner_small" data-role="adloader adloader_ad delayload delayload_done" data-adloader-size="320x50" data-state="adloader_unloaded"  data-withinviewport-options="bottomOffset=100&topOffset=1000000"  data-adloader-position="footerMobileBanner" data-adloader-adtype="mobilebanner" data-adloader-label ></div
       >
  </div>
</div
><header class="trb_nh" data-reg-role="prompt" data-role="nh_cnt">
  <div class="trb_nh_uw"><div class="trb_nh_dss" data-reg-role="base"></div
    ><div class="trb_nh_dss_m" data-reg-role="mob"></div
    ><nav class="trb_nh_un_w"
      ><div class="trb_nh_unh" data-role="nh_t"
        ><svg class="trb_nh_unh_svg"
    ><use xlink:href="#trb_thin_close"
  /></svg
><div class="trb_nh_un_hw"
          ><hr class="trb_nh_unh_hr"
          /><hr class="trb_nh_unh_hr"
        /></div
        ></div
      ><div class="trb_nh_un_ulw" data-role="s8e nh_ulw" data-url="/get-navigationlinks?v=1q2w3_402ef6ace82fbbc9accee1bebc62e628030f1e0"
        ></div
      ></nav
    ><div data-role="nh_search ps" data-ps-url="/searchsuggest?ty=site&q=" data-ps-timedelay="75" 
    ><a href="#" class="trb_nh_sm" data-role="nh_searchButton" data-nh-searchtitle="SEARCH"><svg class="trb_nh_sm_o_svg"
    ><use xlink:href="#trb_magnify_glass"
  /></svg
><svg class="trb_nh_sm_c_svg"
    ><use xlink:href="#trb_thin_close"
  /></svg
></a
    ></div
    ><a href="/#nt=mastheadnavbar"
      ><svg xmlns="http://www.w3.org/2000/svg" class="trb_nh_l"><symbol id="pa" viewBox="120.707 341.588 546.066 109.341"><path d="M203.84 429.478c-8.415 7.896-19.406 12.242-30.95 12.242-24.945 0-45.24-20.294-45.24-45.24 0-24.945 20.296-45.24 45.24-45.24 11.758 0 22.897 4.49 31.366 12.64.57.55 1.305.822 2.04.822.772 0 1.543-.3 2.12-.903 1.128-1.18 1.092-3.04-.08-4.16-9.57-9.22-22.158-14.29-35.444-14.29-28.19 0-51.125 22.93-51.125 51.12 0 28.19 22.935 51.12 51.125 51.12 13.045 0 25.466-4.92 34.975-13.84 1.185-1.11 1.245-2.98.133-4.16-1.115-1.19-2.977-1.25-4.16-.13zm259.048-84.134c-28.343 0-51.4 23.058-51.4 51.402s23.058 51.402 51.4 51.402c28.344 0 51.403-23.06 51.403-51.402s-23.06-51.402-51.4-51.402zm0 96.92c-25.098 0-45.517-20.42-45.517-45.52s20.42-45.517 45.52-45.517 45.52 20.42 45.52 45.518-20.42 45.518-45.52 45.518zM398.37 348.02c0-1.624-1.317-2.94-2.942-2.94s-2.942 1.316-2.942 2.94v87.677l-75.987-89.58c-.03-.03-.06-.05-.08-.078-.08-.08-.15-.15-.23-.22-.07-.06-.14-.12-.21-.17-.08-.06-.17-.11-.25-.16-.08-.05-.16-.1-.24-.13-.09-.04-.18-.08-.27-.11l-.27-.09c-.09-.02-.19-.04-.28-.05-.1-.02-.2-.03-.31-.03-.04 0-.08-.01-.12-.01-.06 0-.1.01-.16.01-.11 0-.21.01-.31.03-.1.01-.19.03-.28.06-.09.02-.19.05-.27.08-.1.03-.19.07-.28.11-.08.04-.16.08-.24.13-.09.05-.18.11-.26.18-.04.03-.09.05-.13.08-.03.02-.05.05-.077.08-.073.07-.15.15-.22.23-.06.07-.12.13-.17.2-.06.08-.11.16-.16.25-.04.08-.09.16-.13.24-.04.09-.07.18-.1.27-.035.09-.065.18-.086.27-.02.09-.036.18-.05.27-.016.102-.027.203-.03.306 0 .04-.01.074-.01.114v95.7c0 1.63 1.315 2.948 2.94 2.948s2.942-1.315 2.942-2.94v-87.67l75.983 89.58c.02.03.06.047.08.07.088.1.186.19.286.273.06.05.116.1.18.146.105.08.22.14.34.202.06.032.12.07.18.1.146.07.3.11.454.15.04.01.08.03.12.04.2.04.4.07.61.07.19 0 .37-.02.55-.05.07-.01.13-.03.19-.05.11-.03.226-.06.337-.1.07-.03.14-.06.21-.1.09-.046.186-.09.27-.15.07-.04.14-.09.21-.14.048-.037.098-.06.14-.1.03-.028.05-.06.08-.08.08-.077.15-.15.22-.23.06-.07.12-.14.17-.21.06-.08.11-.16.16-.248.046-.08.093-.16.13-.243.04-.09.07-.18.1-.27.03-.09.06-.18.085-.27.02-.09.04-.18.05-.272.02-.1.03-.2.03-.31 0-.04.01-.072.01-.112v-95.69zm-101.134-2.33h-80.294c-1.625 0-2.942 1.317-2.942 2.942 0 1.625 1.317 2.942 2.942 2.942h37.204v92.75c0 1.626 1.317 2.943 2.942 2.943 1.625 0 2.942-1.317 2.942-2.942v-92.75h37.205c1.625 0 2.942-1.318 2.942-2.943.002-1.625-1.315-2.942-2.94-2.942zm366.574-1.13c-1.522-.573-3.22.194-3.793 1.714L626.7 434.508l-31.786-88.192c-.005-.014-.013-.025-.02-.038-.04-.108-.096-.21-.15-.313-.036-.07-.064-.144-.105-.208-.06-.088-.13-.166-.19-.25-.06-.067-.1-.142-.16-.205-.07-.067-.14-.124-.21-.186-.08-.065-.15-.134-.22-.19-.07-.048-.14-.084-.21-.126-.1-.058-.2-.12-.3-.166-.02-.006-.03-.016-.04-.02-.07-.03-.13-.04-.2-.064-.11-.037-.21-.075-.32-.1-.09-.02-.18-.03-.27-.04-.1-.015-.2-.032-.31-.035-.09-.002-.18.006-.27.012-.1.006-.2.01-.3.027-.1.016-.19.044-.29.07-.08.02-.16.03-.23.06-.02.005-.03.014-.05.02-.09.034-.18.083-.26.126-.09.043-.18.08-.26.132-.07.042-.13.097-.19.144-.09.066-.18.128-.26.204-.06.053-.11.117-.16.173-.08.083-.16.164-.22.255-.05.062-.08.134-.12.202-.06.1-.12.196-.17.3-.01.014-.02.025-.02.04l-38.69 88.9-31.977-88.726c-.55-1.53-2.24-2.322-3.768-1.77-1.53.55-2.32 2.237-1.77 3.766l34.48 95.694c.003.015.01.027.02.043.02.05.04.096.062.143.05.115.1.226.165.33.03.05.063.1.097.147.07.1.14.194.22.283.04.043.074.086.12.126.1.105.21.202.33.29.02.016.04.035.063.052.143.102.3.185.46.258.014.008.03.02.045.027.03.013.06.018.096.03.13.05.26.092.394.123.05.014.1.026.15.037.17.03.34.053.52.053h.005c.25 0 .5-.042.75-.108.046-.012.09-.02.136-.036.04-.012.08-.017.117-.03.204-.074.394-.173.57-.285.028-.018.05-.043.08-.062.188-.127.35-.272.5-.436.044-.05.085-.09.125-.14.16-.2.3-.42.404-.65 0-.01.01-.02.014-.03l38.686-88.9 32 88.73.06.12c.02.06.05.11.072.17.054.1.114.21.18.31l.09.14c.096.12.2.24.31.35l.036.04c.13.12.267.22.41.31.045.03.094.05.14.08.115.06.23.12.35.17.03.01.06.03.09.04.03.01.05.01.08.02.11.04.22.06.33.09l.15.03c.16.02.32.04.484.04h.01c.157 0 .31-.02.467-.04l.146-.04c.11-.027.22-.05.32-.088.02-.01.04-.01.066-.02.03-.01.06-.03.09-.043.12-.05.24-.107.358-.17.05-.03.097-.056.14-.085.14-.09.27-.187.4-.3.01-.01.02-.01.02-.017.13-.12.24-.25.35-.39.03-.04.055-.086.083-.13.07-.1.13-.2.19-.31.03-.06.06-.11.08-.17.02-.04.05-.08.06-.124l36.14-95.69c.57-1.516-.194-3.213-1.714-3.79z"/></symbol><use xlink:href="#pa" /></svg></a
  ></div
  ><div class="trb_nh_lw"
    ><span class="trb_nh_t" data-dt="Jun. 19, 2017" data-dt-wd="Monday"></span><ul class="trb_nh_ln"
        ><li class="trb_nh_ln_li"
            ><a href="/courant/#nt=tertiarynavbar"  class="trb_nh_ln_a">Courant News</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/food-drink/#nt=tertiarynavbar"  class="trb_nh_ln_a">Food & Drink</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/pictures/#nt=tertiarynavbar"  class="trb_nh_ln_a">Pictures</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/music/#nt=tertiarynavbar"  class="trb_nh_ln_a">Live Music</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/events/#nt=tertiarynavbar"  class="trb_nh_ln_a">Search Events</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/family/#nt=tertiarynavbar"  class="trb_nh_ln_a">Family Fun</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/arts-theater/#nt=tertiarynavbar"  class="trb_nh_ln_a">Arts</a
          ></li
        ><li class="trb_nh_ln_li"
            ><a href="/best-of/#nt=tertiarynavbar"  class="trb_nh_ln_a">Best Of</a
          ></li
        ></ul
    ><a href="/weather/?regionalZipCode=06103#nt=tertiarynavbar" class="trb_nh_w" data-content-weather="overcast"><div class="trb_nh_wt"><svg class="trb_nh_wt_svg"
    ><symbol id="trb_wh_overcast" viewBox="0 0 32 32"><path d="M23.313 18.563h-2.5q-.5 0-.5-.5t.5-.5h2.5q1.375 0 2.375-.97t1-2.374-1-2.38-2.375-.97q-1.25 0-2.188.87-.25.185-.53.06t-.345-.44q-.125-2.187-1.78-3.75t-3.907-1.56q-2.188 0-3.813 1.47t-1.875 3.6q-.063.25-.25.375t-.375.06q-.375-.063-.75-.063-1.25 0-2.156.874t-.906 2.13q0 .25.063.5.07.5-.43.563t-.56-.375q-.06-.313-.06-.688 0-1.625 1.19-2.813T7.5 10.5h.438q.438-2.314 2.313-3.876t4.32-1.564q2.63 0 4.57 1.818 1.625 1.5 2 3.625 1.063-.625 2.188-.625 1.814 0 3.095 1.28t1.28 3.064-1.28 3.063-3.093 1.283zm-4.125.093q0-1.156-.813-2t-2-.844q-.375 0-.75.125-.813-1.438-2.438-1.438-.125 0-.313.06-1.25-1.63-3.25-1.63-1.688 0-2.875 1.12-1 .875-1.25 2.19h-.19q-1.07 0-1.85.75t-.78 1.842.78 1.843 1.84.75h11.07q1.19 0 2-.813t.812-1.97zm-13.47-1.343q.22.063.44-.063t.218-.375q.125-1.25 1.063-2.094t2.18-.84q1.69 0 2.62 1.44.19.25.563.19.19-.06.375-.06 1.31 0 1.75 1.25.06.19.25.28t.436-.03q.375-.185.75-.185.75 0 1.28.53t.532 1.28-.53 1.28-1.285.53H5.316q-.69 0-1.155-.47t-.47-1.122.47-1.124 1.15-.47q.19 0 .41.065zm22.157-6.875q.25-.5.188-1.063-.063-.75-.563-1.28t-1.25-.657V7.25q-.125-1.313-1.156-2.188t-2.344-.75q-1.813.188-2.625 1.875-.188.438.25.656t.625-.28q.563-1.126 1.813-1.25.938-.064 1.656.53t.78 1.47q.06.312 0 .562t.12.438.44.125h.06q.44-.063.81.25t.372.75q.064.313-.06.563-.19.5.25.69.06.07.19.07.31 0 .434-.31z"/></symbol><use xlink:href="#trb_wh_overcast"
  /></svg
>75&deg;</div
      ></a
      ></div
></header>

  <div id="trb_ad_oop" data-role="oopadloader_oopad" class="trb_oopAd"></div
>


  

  

  

  

  

  

  

  


  <script>trb.run.push(function(){i$('nh');});</script>
<script id="trb_end">trb.userTiming("trb bottom");</script
><script>trb.data.gigyaUrl = "http://cdn.gigya.com/js/gigya.js?apiKey=2_sOFwjiEcLtiAQCXSTLfSPwMROx2x2ODjgjA0iYnzhlEuGhCktFEVsFwW3fBpidc9";</script
><script>
    trb.data.facebookAppId = '312570883661';
    trb.data.facebookId = 'ctnow';
  </script
><script>trb.run.push(function(){i$("carousel");});</script
><script>
  trb.run.push(function(){
        trb.data.page.sectionPath = '/music/';
        trb.data.page.sectionName = 'Music';
        trb.data.page.pageTitle = 'Alt-Rocker Mark Mulcahy Discovers His Voice On New Album - CT Now';
                  
          trb.data.page.slug = 'hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621';          
          trb.data.page.title = 'Alt-Rocker Mark Mulcahy Discovers His Voice On New Album';
          trb.data.page.author = 'MICHAEL HAMAD';
          trb.data.page.background = '<p>Singer-songwriter Mark Mulcahy, who\'ll perform his entire new album, &quot;The Possum in the Driveway,&quot; at Lyric Hall in New Haven on June 22, is Connecticut alt-rock royalty. Mulcahy hoisted New Haven music up onto an international stage with Miracle Legion, the band he co-founded with guitarist Mr....</p>';
          trb.data.page.thumbnailURL = 'http://www.trbimg.com/img-5947d318/turbine/hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621';
          trb.data.page.ads = trb.data.page.ads || {};
          trb.data.page.ads.options = trb.data.page.ads.options || {};
          trb.data.page.ads.options.slug = trb.data.page.ads.options.slug || 'hc-ctnow-mark-mulcahy-lyric-hall-new-haven-0622-20170621';
        
  });
</script>
  <script>trb.run.push(function(){i$('sc');});</script>

  <script>trb.run.push(function(){ !window.gigya && trb.vendor.isEnabled('gigya') && i$.require(trb.data.gigyaUrl); });</script>
  <script>trb.run.push(function(){i$('gallery');});</script>  <script>trb.run.push(function(){i$('lightbox');});</script>
  <script>trb.run.push(function(){i$('cm');});</script>

  <script>trb.run.push(function(){i$('pagination');});</script>
<script type="trb/css" data-css-key=reskin>
</script>
<script type="trb/css" data-css-key=lightbox>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</script>
<script type="trb/css" data-css-key=videoscroll>
</script>
</body>
</html>